Hlavní navigace

Debian unstable a nežádoucí jádro ...

15. 1. 2007 22:51 (aktualizováno) | miklik

Se dějí nevídané věci. Jsem si nainstaloval Debiana z unstable zdroje s jádrem 2.6.8–2-i368. Protože v něm potřebují gcc-4.1 pro cross kompilaci jádra na arm procesor v Palmu.

A co mě nečekalo za překvapení při doinstalovávání balíčku přes apt. Systém měl kolizi balíčku initrd-tools a libc6. Tak chtěl initrd-tools odstranit, ale na těch je závislý kernel, tak se apt rozhodl, že by chtěl odinstalovat kernel???

Nenašel jsem rozumné řešení, tak jsem jádro zazálohoval, nechal odinstalovat a pak obnovil ze zálohy. Ještě jsem však nerebootoval, tak pak uvidím, jak to dopadne bez initrd-tools.